[NTLK] Sick Newton

Dan dan at dbdigitalweb.com
Fri Jan 8 20:22:44 PST 2021

Hi everyone.
I have a sick newton.  A MP2100U.  A few months ago the batteries ran out and I pulled them out of the battery tray and put in a fresh set of rechargeables.  Only to find out it wouldn't boot up.

I ran it through the usual tricks and still wouldn't.  In the end I put in a set of alkalines and it fired right up.  I thought it strange but since it was working I left it at that and didn't do anything more.  The batteries died as usual in a couple of months.  And I was using it when they died.  Was about to put in a fresh set when the screen went blank.

This time though I can't get it to power up even on alkalines.  I have tried reset, holding down power while reset.  Holding down reset for 30 sec without batteries, etc.

Right now it is sitting without batteries for a day or two to see if that does it.

Anyone ever ran into this where it didn't like rechargeables but ran fine on alkalines?  My memory at the moment might be fuzzy regarding this, but I don't recall it being mentioned.

Any suggestions/ideas?  It might work in a day or two after sitting without batteries, but thought I would ask and see if I was missing something obvious.


More information about the NewtonTalk mailing list