[NTLK] Getting back in - some E-Mate questions

Stephen Pereira stephen.m.pereira.sr at gmail.com
Sun Feb 13 08:01:04 PST 2022

Good day, folks,

As I am continuing my experiments with my backup issue, I have a thought that I’d like to put out and perhaps someone can verify.

My NBU for Windows says its Copyright is 1996.  My Dell Mini PC has a 150GB hard disk, with 143GB free.  Is it possible that the NBU cannot properly decipher the large hard disk that it was not prepared for in 1996, and so makes the incorrect determination that the disk is full?  If the NBU is expecting a hard disk with only 100’s of MB, could it simply be not seeing any HD space at all?

I’d like to hear anyone’s thoughts about this.

Also, I have another issue to throw out to you all.  I have an ImageWriter serial cable going from my E-Mate to a DB25-to-DB9 adapter, then a DB9 Null Modem, and finally a RS232-to-USB adapter going to the Dell Mini PC.  This is the setup that is working for me with NBU on the Dell PC.   I can load packages onto my E-Mate, but I cannot do a backup.  

I have discovered the NCK for Macintosh that is supposed to work on modern Macs.  If I unplug my cable and adapter string from the Dell Mini PC, and plug in on my MackBook Pro, I can get the NCK running, and I can set it to use the RS232-to-USB adapter, and I can set it for 38400 BPS, but I cannot establish a connection between the NCK on the Mac and my E-Mate.

I see that the NCK properly detects the RS232-to-USB adapter for the serial port on the Mac, and I set the proper rate, but no connection using the exact same cabling that works with the NBU on the PC.  I welcome any advice that you may have to offer about getting the NCK on Mac to work properly.  I’m hoping that since the NCK on modern Mac is much more modern that this would be the best way to go.

My MacBook Pro is running the latest OS, Monterey version 12.2.1.

Please help if you can!

- - -
Stephen Pereira
Bedford, NH  03110

> On Feb 10, 2022, at 12:51 PM, Stephen Pereira <stephen.m.pereira.sr at gmail.com> wrote:
> Good afternoon, folks,
> Long ago, I had a Newton 110, and of course it is long gone.  Recently I came across a good deal on a lightly used E-Mate 300 that was used in a school system.  I had to do a hard reset to get it back into full E-Mate mode, and it appears to be working - almost completely.
> It operates sluggishly, as I remember with the old 110, but that’s to be expected.  I got Newton Backup Utility working on a Dell Mini laptop PC, and I can make a good connection to the E-Mate via a few adapters.  When I select the Backup process, either from the PC side or from the E-Mate side, I get a response that the backup failed because the computer’s disk is full.  When I try from the PC side, the error message comes up on the PC, and when I try from the E-Mate side, the error message comes up on the E-Mate.
> So, is there some other setting in an E-Mate that was used in a school that would block the Newton Backup Utility from being able to perform a backup?
> Moving on, I have also tried to use a PCMCIA card.  First, I have a memory card that shows up on the E-Mate when plugged in with the message that this type of card is not supported and will be available only as read-only.  The interesting thing is that there is a previous Newton backup on the card from February 2006, and the E-Mate asks me if I want to restore from it.  The card does have a write-protect switch, but it appears to make no difference which position it is in.  The card always comes up as unsupported and read-only.  So, far, I have not yet attempted to perform the restore, so I don’t know if it would be successful.
> I also purchased a PCMCIA adapter card for Compact Flash cards.  I have two Compact Flash cards, one is 64MB and the other is 4MB.  The PCMCIA Adapter Card initially came up with error messages, and I have been able to install the ATA Support 1.0 package via my Newton Backup Utilities on the PC.  That has both of the Compact Flash cards working in the PCMCIA adapter - almost completely.  I can read and write to the Compact Flash cards, and I can partition them if I wish.  I thought that I remember hearing that the E-Mate may only recognize up to 4MB, but it sees the 64MB CF card as 66MB.  It allows a partition of 4MB, plus a second partition for all the rest, so I tried that.
> Now for the part that is not completely working.  Using either of my CF cards, if I try to perform a backup onto the CF card, I receive a blank dialog box with nothing to do but make it go away.  Frustrating!  Again, is there some setting or jumper somewhere that I am missing in order to allow my E-Mate to perform a backup?
> Thanks very much for listening.  I hope that you folks can get me moving in a good direction with the E-Mate.
> Oh, and one more question.  I’m hoping to install a terminal emulator package to play around as a terminal on my other vintage computers.  I have installed PT-100 from the Archives, but the 5 minute cripple is not ideal.  Can anyone suggest a good basic terminal emulator?  I don’t really need anything fancy, as this is just playing around, but I would like more than 5 minutes at a time!
> Thanks again.  I apologize for my baby beginner questions!
> smp
> - - -
> Stephen Pereira
> Bedford, NH  03110

More information about the NewtonTalk mailing list