[NTLK] Subject: Re: Touchscreen problem on my MP2000

Simone Picchioni simonepsp at gmail.com
Wed Dec 24 16:27:24 EST 2014


thanks for your answer.
I've check 1st and 4th trace with a multimeter and there's a continuity.
I'm not actually able to check 2nd and 3rd trace because terminal points
are covered by a plastic film.

I've added a little piece of folded paper to compress better but
touchscreen still doesn't work :(

I wish you an happy christmas :)

2014-12-24 19:41 GMT+01:00 iSpinn <ispinn at gmail.com>:

> There's an opaque, silicone insert under the 4-conductor cable, pretty
> close to the two protruding pins in image 2LpEeX.jpg. I've found that over
> time that insert gets compressed to the point where the contacts are no
> longer made with enough compressive force between the flex cable and its
> mating PCB. In my Newts, I've flipped it upside down, or added a shim of
> folded paper to raise it up and force some additional compression.
>
> It's impossible to say yet, but I doubt it's the board that's bad--it's
> usually a simple problem, not a complex problem. I'm concerned about the
> blue oxidation along the one trace in the length of the flex cable,
> possibly indicating a weakened metal trace in the flex cable that may have
> a hairline crack somewhere along its length.
>
> Have you checked for continuity along all of the flex connector paths?
>
> *Doug *
> ----------------------------------------------------------------------
>
> The NewtonTalk Mailing List   http://newtontalk.net/
> The Official Newton FAQ       http://splorp.com/newton/faq/
> The Newton Glossary           http://splorp.com/newton/glossary/
>


More information about the NewtonTalk mailing list