[NTLK] Touchscreen problem on my MP2000

Simone Picchioni simonepsp at gmail.com
Wed Dec 24 11:21:00 EST 2014


I've already cleaned terminal contacts on touchscreen cable and contacts on
motherboard PCB.
Everything works except touchscreen :( It is unbelievable.


2014-12-24 15:09 GMT+01:00 Woody Smith <woodysmith at me.com>:

> In the years that I have followed this list, I don’t recall hearing about
> a total failure of the digitizer without physical damage.
>
> When you reassemble be sure to clean the contacts carefully. Clean
> contacts on ROM board.
>
> Even though you cannot do a hard reset without display input, I would try
> anyways.
>
> Good luck
>
> Woody
>
>
> > On Dec 24, 2014, at 6:44 AM, Simone Picchioni <simonepsp at gmail.com>
> wrote:
> >
> > thank you for your answers.
> > Digitizer cable seems ok.
> > I'm posting some photos, it can help understand what's the problem.
> >
> > http://img537.imageshack.us/img537/1941/WIB1Dd.jpg
> > http://img538.imageshack.us/img538/1017/2LpEeX.jpg
> > http://img673.imageshack.us/img673/31/3WQ59w.jpg
> > http://img904.imageshack.us/img904/4278/acYYu4.jpg
> > http://img661.imageshack.us/img661/1559/gbYa6b.jpg
> > http://img538.imageshack.us/img538/7857/VgcwoP.jpg
> >
> > I've also cleaned all the touchscreen surface.
> > Thanks :)
> >
> > 2014-12-24 4:18 GMT+01:00 Andrei Chichak <newton at chichak.ca>:
> >
> >> From the look of all of the ick along the edge of the screen, I’d say
> the
> >> digitizer is being pressed when it’s not being pressed.
> >>
> >> Clean all of the goo along the edge and run a business card between the
> >> bezel and the screen.
> >>
> >> A
> >>
> >>
> >>> On 2014-December-23, at 17:06, Simone Picchioni <simonepsp at gmail.com>
> >> wrote:
> >>>
> >>> Hi,
> >>>
> >>> I'm looking for help! Touchscreen doesn't work on my beautiful
> messagepad
> >>> 2000 :(
> >>> It turns on but touchscreen doesn't work :(
> >>>
> >>> http://oi61.tinypic.com/1zpgoch.jpg
> >>>
> >>> I thought that acid from dead battery ruined touchscreen cable so I
> >> cleaned
> >>> it using a specific product for PCB pins but I didn't solved :\
> >>>
> >>> Someone has any idea on how to solve this situation?
> >>>
> >>> Thank you a lot,
> >>> Simone :)
> >>> ----------------------------------------------------------------------
> >>>
> >>> The NewtonTalk Mailing List   http://newtontalk.net/
> >>> The Official Newton FAQ       http://splorp.com/newton/faq/
> >>> The Newton Glossary           http://splorp.com/newton/glossary/
> >>
> >> ----------------------------------------------------------------------
> >>
> >> The NewtonTalk Mailing List   http://newtontalk.net/
> >> The Official Newton FAQ       http://splorp.com/newton/faq/
> >> The Newton Glossary           http://splorp.com/newton/glossary/
> >>
> > ----------------------------------------------------------------------
> >
> > The NewtonTalk Mailing List   http://newtontalk.net/
> > The Official Newton FAQ       http://splorp.com/newton/faq/
> > The Newton Glossary           http://splorp.com/newton/glossary/
>
> ----------------------------------------------------------------------
>
> The NewtonTalk Mailing List   http://newtontalk.net/
> The Official Newton FAQ       http://splorp.com/newton/faq/
> The Newton Glossary           http://splorp.com/newton/glossary/
>


More information about the NewtonTalk mailing list