[NTLK] NCX problem

Don Zahniser dzahniser at rochester.rr.com
Tue Aug 24 07:54:28 EDT 2010

Hi, Simon -

I'll send along the crash logs, but before I do I want to try a  
couple of things to see if I can provide more data:

1) The open-source PL2303 driver shows up in Network Preferences, but  
I have it 'turned off'; it hasn't affected performance in the past,  
but perhaps the changes you've made would alter the need for having  
it 'active'.  I also had the internal modem 'turned off' but NCX  
found that, too.  I'll turn all the things that Network Preferences  
recognizes as network interfaces on to see if that affects the crash.

2) I also have an archive of Prolific's pl2303 driver.  Up until now,  
I haven't seen a reason to prefer one over the other for my  
purposes.  It's been awhile, but I seem to recall that Prolific's  
driver installs as a kext, whereas the open source driver does not.   
The Prolific driver does not show up in Network Preferences as a  
network device.  I'll be curious to see whether the Prolific driver  
suffers from the same issue under NCX.

This may take a couple of days, as I am trying to set up a pasture  
for my buck goats, help with canning/freezing stuff from the garden,  
and also have a job...

  On Aug 24, 2010, at 5:07 AM, Simon Bell wrote:

> On 23 Aug 2010, at 18:30, Don Zahniser wrote:
>> I just tried the new version of NCX for the first time.  It launched
>> for me, but wouldn't connect to my MP2100 via serial.  Upon checking
>> the preferences, it showed IRDA as the serial connection.
> The serial connection code has been changed, mainly to make the MNP
> protocol implementation more robust. There are two other changes that
> you have picked up here.
> o  The popup list of serial devices available shown in NCX’s
> Preferences now includes ALL serial devices. Previously some users
> found they could not select the right device.
> o  The preferred serial device is now saved as a device path string,
> not an index into the list of devices. Previously, advanced users
> could not set up a path to a special serial device.
> This means that the first time you launch NCX 1.3(42) you will need to
> set your serial device preference, since the previous setting is
> meaningless and NCX will choose the first device it finds. My bad, I
> forgot to mention this in the release note.
>> I tried changing it to the PL2303 open source driver that I've been
>> using
>> with my generic USB-Serial adapter, and got a crash when I closed the
>> preference dialog.
> There does seem to be a problem with the PL2303 driver. I don’t know
> why -- NCX uses only POSIX calls to the serial device. Not having the
> requisite hardware I can’t reproduce this crash but I shall see what I
> can do...
>> Anyone need a crash log?  I have a few to spare...
> Please send them my way.
> Simon
> ====================================================================
> The NewtonTalk Mailing List - http://newtontalk.net/
> The Official Newton FAQ     - http://splorp.com/newton/faq/
> The Newton Glossary         - http://splorp.com/newton/glossary/
> WikiWikiNewt                - http://tools.unna.org/wikiwikinewt/
> ====================================================================

Don Zahniser

More information about the NewtonTalk mailing list