[NTLK] NCX problem

Simon Bell simonbell at me.com
Tue Aug 24 05:07:12 EDT 2010

On 23 Aug 2010, at 18:30, Don Zahniser wrote:

> I just tried the new version of NCX for the first time.  It launched
> for me, but wouldn't connect to my MP2100 via serial.  Upon checking
> the preferences, it showed IRDA as the serial connection.

The serial connection code has been changed, mainly to make the MNP  
protocol implementation more robust. There are two other changes that  
you have picked up here.

o  The popup list of serial devices available shown in NCX’s  
Preferences now includes ALL serial devices. Previously some users  
found they could not select the right device.
o  The preferred serial device is now saved as a device path string,  
not an index into the list of devices. Previously, advanced users  
could not set up a path to a special serial device.

This means that the first time you launch NCX 1.3(42) you will need to  
set your serial device preference, since the previous setting is  
meaningless and NCX will choose the first device it finds. My bad, I  
forgot to mention this in the release note.

> I tried changing it to the PL2303 open source driver that I've been  
> using
> with my generic USB-Serial adapter, and got a crash when I closed the
> preference dialog.

There does seem to be a problem with the PL2303 driver. I don’t know  
why -- NCX uses only POSIX calls to the serial device. Not having the  
requisite hardware I can’t reproduce this crash but I shall see what I  
can do...

> Anyone need a crash log?  I have a few to spare...

Please send them my way.


More information about the NewtonTalk mailing list